WEB-O-RAMA VERSION HISTORY

Notes

Web-O-Rama Professional Available on CD

If you’re using Windows 98, or have installed Microsoft’s Internet Explorer 5 (IE 4.01 SP1 will work, too) you may want to try Web-O-Rama Professional. This version features a WYSIWYG (“what you see is what you get) tab that allows you to switch instantly between your HTML code and a Web View WYSIWYG window. Extremely cool! Send $19.95 to Kevin Gunn, P.O. Box 442155, Lawrence  KS  66044-8933, for Web-O-Rama Professional on CD. Please send me an e-mail telling me you’ve mailed a request so I’ll know to check my post-office box! For $14.95, I will e-mail you the zipped weborama.exe file (requires installation of the latest full version of Web-O-Rama to work properly). Money semi-cheerfully refunded if you experience any problems with the WYSIWYG tab.

Help Keep Web-O-Rama Free

If users in a financial position to do so would consider making modest donations to help with programming costs, I can continue to offer Web-O-Rama as donationware rather than traditional shareware (timed or limited to a certain number of uses without a registration key). Unfortunately, donations have been so sparse that it’s doubtful I can keep offering Web-O-Rama on the honor system. Programming takes both time and money, neither of which I seem to have enough of these days. If you find the program useful, please consider making a small donation. I would be grateful. My mailing address is Kevin Gunn, P.O. Box 442155, Lawrence  KS  66044-8933. Even $1 would help. International money orders are more than welcome from overseas users. If you mail a donation, please send an e-mail to me at kgunn@cjnetworks.com letting me know. Because I don’t get many donations, I don’t check my post-office box very often.

Web-O-Rama Now Available on Floppy Disks or CD

If you’d like a copy of the latest version of Web-O-Rama on floppy disks or CD, write to me at Kevin Gunn, P.O. Box 442155, Lawrence  KS  66044-8933, or e-mail me at kgunn@cjnetworks.com for details. The price [fall 1999] is $9.95 for floppies and $14.95 for a CD, which includes the cost of materials, postage, and handling. Checks and money orders (including international money orders) accepted. Vile karma will descend upon you if your check bounces.

Updates

Please check my site at http://people.delphi.com/krgunn/index.html for product updates. Download the latest version (check beta versions, too) before reporting bugs. New versions are posted frequently.

Important Installation Notes

Please read install.doc before installing this program! There is important installation information contained in it.

Changes

Latest Changes (Current Version)

· New, improved splash screen! The picture of me is smaller!

· On some of the dialogs (Body, Image, Links, Rules, and Sound), there is a feature to use the relative path to graphics, files, and sounds. I have triedto make this more intuitive and consistent. The new implementation should be easier to use. You can “Set Root Folder…” on the Preferences dialog and toggle “Use Root Folder…” on and off. The root folder should be the main folder containing the Web pages you’re working on. If your main folder is mysite, your images are in subfolder images, and you add an image called mygif.gif to your Web page using the relative path feature, the HTML code will interpret the path as images/mygif.gif (<IMG SRC=“images/mygif.gif”>). This feature becomes more comprehensible with use. In addition, there is a check box on each of the dialogs that utilize the relative path to set “Name” as the default; otherwise, “Path” will be used.

· Added a “Copy [Image or Sound] to Selected Folder” button to the dialogs that use the relative path feature. This replaces the check box that performed a similar but less intuitive function.

· Three Help files, for HTML 3.2, HTML 4.0, and style sheets, have been added, courtesy of (and used with permission of) the Web Design Group. Please note that the inclusion of these Help files does not add anything to the cost of Web-O-Rama, and that the help files are freely available at the Web Design Group’s Web site (http://www.htmlhelp.com).

· Web-O-Rama now supports drag and drop. Single or multiple files can be dragged from Windows Explorer to Web-O-Rama, where they will open normally. Files can’t be dropped onto Web-O-Rama’s editing window because this feature would disable internal text drag and drop. You can drop files beside the editing window if the editing window isn’t maximized, or anywhere on Web-O-Rama if all files are closed. If you’ve created an icon for Web-O-Rama on your desktop, you can drag files onto the icon to start Web-O-Rama and open the files.

· A new tab, “Color Chart,” added to the Hex Value dialog. This is a visual representation of the 216 “Web-safe” (non-dithered) colors. Pausing the mouse cursor over a color will display the hex value. Clicking a color will return you to the first tab, where you can save the color or add it to your HTML document.

· Much improved “Quick View” on Image dialog.

· Minimizing Web-O-Rama will close any open forms so they aren’t visible once the main Web-O-Rama screen minimizes.

· Option to “Remove HTML Tags from Text” added under main “Text” menu item.

· More efficient code implemented for some of the dialogs. The dialogs that access fonts now load much faster.

· Additional font drop-down lists added to Body and Font dialogs, allowing the selection of multiple fonts.

· A “Close file” button added to the toolbar immediately to the right of the “Open file” button.

· Removed option to use Microsoft Word as an external spell checker. This had never worked very well and was causing problems on computers without Word. A built-in spell checker will be included in future versions of Web-O-Rama. Users with Word can paste HTML files from Web-O-Rama into Word, spell-check them, then paste them back. That’s all the Word function was doing.

· There is now a “Copy to Clipboard” feature. I’ve added buttons, to the right of the “OK” button on the dialogs, that will copy the dialog data to the clipboard, when “OK” is pressed, so the data can be copied to other HTML documents. If the “Copy to Clipboard” button is blue and gray, the feature is disabled. If it’s blue and white, “Copy to Clipboard” is enabled.

· Removed Calendar dialog. A calendar is now accessible on the Character dialog.

Summary of Changes in 6.89

· Added “Quick View” tab to Image dialog. This allows fast previewing of graphics files.

· Due to some goofy coding, the Links dialog wasn’t working correctly. It has been fixed.

· Problem with Metaname dialog fixed. I don’t know if this was a problem in 6.71 or not.

· Added “HTML Document Type Declaration (DTD) Style” to Preferences dialog. This setting can affect the way browsers interpret the HTML code. Inexperienced users should leave this selection at the default setting (“HTML 3.2”) or change to “HTML 4.0 Transitional.” 

· Some terminology changes to the interface. “Directories” are now referred to as “Folders” throughout.

· Added a Page Creator dialog, accessible under the “Insert” menu (“Start Page Creator…”). This allows users to quickly build a Web page using TITLE, META, and BODY attributes. Easy access to the Meta and Body dialogs from the Page Creator. Option to save the template as a file, which can then be easily inserted into HTML pages using “Insert” ( “File…”.

· A Web-O-Rama user pointed out to me that Internet Explorer and Netscape use different BODY parameters for margins. Utter foolishness! I changed the Body dialog to reflect this … there is now a “Margins” tab. It is possible to include margin settings for both Internet Explorer and Netscape simultaneously, although I have not tested this with Internet Explorer 3.X or Netscape 3.X or lower.

· An “Include Template” checkbox added to the Body dialog. Checking this box will frame the BODY attributes with a standard set of HTML tags.

· Fixed minor glitch in “Insert” ( “File” operation.

· Improved ability of Sound dialog to stop playing selected sounds. 

· Miscellaneous improvements and minor bug fixes.

Summary of Changes in V. 6.71

· A File View tab has been added to the main editing window. File View can be toggled on or off (under the View menu item). The first tab, Files, shows the current directory and file list. Clicking on a file opens it (if it isn’t already open) or brings it to the front (if it’s currently open). Selecting an image file opens the Image dialog. The second tab, Tags, is a tree of the most commonly used tags. Selecting Insert will insert the tag (without parameters) when the tag is clicked. Selecting View will open the Tag List dialog with the selected tag highlighted and a description provided. The tag can then be inserted from the Tag List dialog, if desired. The Characters tab is a tree of keyboard, special, and accented characters (I found that I needed this feature even though it duplicates much of the Characters dialog). Clicking on one of the characters adds it to the document.

· The Frames dialog has been completely rewritten to be more user-friendly and versatile. Some very cool features.

· The Links dialog has been redesigned to be much more intuitive.

· Many of the other dialogs have been redesigned to be more compact.

· The Hex Value dialog has an interesting new feature … an Image Color tab. Select an image and move the mouse over it. The little box between “Find Image” and “Use Color” will change color to match the color of the image under the mouse pointer. Clicking on the image will add the color value to the “Values” box. Clicking on “Use Color” will snap you back to the first tab with the selected color value added. It can then be inserted into the document. The “Match Safe” button will snap you to the first tab with the closest “safe color” match to the selected image color value (since there are only 216 “safe” colors, the match may not be terribly close). I have found this extremely useful in creating “color coordinated” Web pages.

· I got rid of all the “Export Data” tabs and drop-down lists. These were utilized by the program itself and were not actually a user feature. This saved some space and I think it made the program less confusing.

· Many miscellaneous improvements to the code and program interface.

Summary of Changes in V. 6.50

· Many, many improvements to the code.

· The Horizontal Rule dialog has been put back in (there’s a button on the dialog toolbar).

· The Recent Files and Recent Directories lists now show the most recently opened file or directory as the first item in the list. I’d been meaning to fix the lists but hadn’t had the time. A Visual Basic programmer in Brazil (Carlos Yoshinobu Une) sent me an e-mail containing some interesting and helpful code, including a more sophisticated method of implementing the lists. I was able to adapt it for inclusion in Web-O-Rama. Thanks, Carlos!

Summary of Changes in V. 6.33

· A Preferences dialog has been added. This simplifies Web-O-Rama’s menus and presents the preferences in a more easily understood manner. “Preferences” is on the main menu at the top of the program.

· Due to a minor coding error, some users may not have been able to set a Default Folder or open files from the Recent Files list. This has been fixed.

· A Copy File dialog has been added. Its operation is self-explanatory. I don’t know how useful others will find this, but I frequently want to copy or move files without exiting or minimizing Web-O-Rama.
· A number of mostly minor bugs have been fixed.

· When selecting multiple files to open, if the combined length of all the file names exceeded 256 characters, an error occurred. This has been fixed.

· Canceling a print operation no longer generates an error.

· In some cases, selecting the “Autosave File” on some of the dialogs may have resulted in an error or a failure to save the file; this has been fixed. Other minor file-handling bugs have been fixed and in general all file-handling has been enhanced.

· Using  Microsoft Word to spell check documents now works, although you have to spell check the file in segments if the file exceeds 32 kilobytes in length.

· Cutting and pasting or copying and pasting occasionally resulted in the material showing up double-spaced. This has been fixed.

· File View and Directory View removed (see below).

· Additional user options (see the Preferences dialog).

· The image viewer on the Image dialog now “snaps” to the center of the image if the image is larger than the viewing area.

Summary of Changes in V. 6.0

· Interface improvements to all the dialogs.

· I installed Visual Basic 6 on August 29. VB6 improves the function of many of the controls, including the Rich Text Box, which comprises the main editing window. The Rich Text Box now prints “normally.” VB6 also compiles the code more efficiently, resulting in a smaller .exe file.

· You can now save custom colors using the Hex Value dialog.

· A Style Sheet dialog added. Although its operation is reasonably intuitive, an understanding of style sheets is necessary in order to use it. This dialog is still in development. User input would be appreciated.

· Major improvements to the Tag List dialog. A row of windows across the bottom displays the browsers and HTML version each tag and each attribute works with. Red indicates no support or partial support, green indicates full support. This information was painstakingly gathered from a variety of public-domain resources and represents the most recent available.

· Added a Splash Screen (can be toggled off under the “Options” menu) that appears when the program first starts.

· If you click on “Date” under the “Insert” menu a dialog opens showing a calendar. A drop-down list gives you a number of options.

· Major improvements to the interface, including code enhancements that result in smaller resource use..

· The following was removed starting with v. 6.15 due to insurmountable errors. A new implementation will be added to future versions. [A new Open-file View toolbar added. Clicking on it under the “View” menu opens a viewing window beneath and to the left of the toolbars that shows all currently open files on the first tab and drive / directory / files on the second tab. Clicking on a particular file name on the “Open Files” tab brings the file to the front. You can open files from the “Directories” tab. Can be toggled on and off.]

· Improvements to the dialogs. The Image dialog now has a drop-down list for “Alternate Text.” After selecting an image, this box will contain several “Alternate Text” options. I found that I liked having the image dimensions listed. If you don’t want to use one of the options from the list, you can type one of your own. Default is “None.”

Summary of Changes in V. 5.03 

· “Unformat Text” option added under “Text” menu. If you’re cutting and pasting from a Word document or other document that contains formatting for typeface, type size, etc., “Unformat Text” will remove the formatting.

· All of the option buttons replaced with “graphical style” push buttons. 

· “Spinner” controls added beside all the fill-in boxes that require numbers. I’ve been putting off doing this because it requires an additional .ocx and has entailed the release of a new full version in order to install the .ocx on users’ systems. It significantly enhances the program, however, and I felt it was worth it.

· You can now copy image and sound files from other places on your hard drive to the directory you’re working in without having to exit Web-O-Rama. On the Body, Image, and Sound dialogs, there’s an “Autosave” checkbox. Check it to have images and sounds saved to the selected directory. “Autosave” will not overwrite a file of the same name (you’ll have to do this manually).

· Option added (or “re-added,” under the “Options” menu) to have cursor “Always Between Inserted Tags” or “At End of Inserted Tags if Text Selected.” The purpose of this feature may not be immediately self-evident, but it’s something I personally use. The first option is the default. The second option is particularly useful if you’re inserting tags for the first time into a text file rather than creating an HTML file from scratch. 

· New “flat” toolbar style (optional) and several redrawn graphics.

· The option to “Color Tags as You Work” has been removed for now. It wasn’t a very “smart” feature and it was easy for it to get stuck on the tag color. This has saved some space and has increased the program’s speed. There are some bugs in Visual Basic 5 that make a more efficient routine impossible (or at least painful). I’m hoping the bugs are fixed in Visual Basic 6, which is due out at the beginning of September, 1998. Look for Web-O-Rama 6.X about mid-September.

· All screen fonts available on your computer are now “gathered” by Web-O-Rama when you start the program. Although the program may appear sluggish when loading (it takes about as long as it does when you use the normal Windows Font dialog . . . slower on some computers than others, depending on the number of fonts you have), you will be able to access the fonts from the various dialogs without “going out” to the Windows Font dialog. Selecting fonts (from the drop-down lists) is significantly faster from the dialogs! The font of the drop-down lists changes to the selected font. Don’t freak if you select a symbol font and you can no longer read anything on the menu . . . just hit your “up arrow” or “down arrow” key to move to the next or previous font. The font changes only where there is no “font sample” box on the dialog.

· Several of the dialogs now have an option to “Include Relative Path to Image from Selected Directory” (drop-down list). If your images or sound files are in a subdirectory of your main HTML directory, selecting the main directory path will allow the images to display and the sounds to play when using “View in Browser.” If your subdirectory structure reflects the structure of your Web site, no path corrections will be necessary before uploading Web pages. This feature becomes more clear with use. If all your images and sounds are in the same directory as your HTML pages, however, it won’t appear to do anything (paths are unnecessary in this situation).

· Several additional tags added to “Insert” menu, including such tags as <PRE> and <BLOCKQUOTE>.

· Many many enhancements to the dialogs.

· Support for up to six user-defined browsers (suggestion from a designer . . . I didn’t realize anyone had more than two or three). When searching for browsers other than Internet Explorer or Netscape, remember to change the “type of file” drop-down at the bottom of the Windows Find dialog to “All files (*.*)” or you will be unable to see the .exe files! I have been fooled by this myself.

· Eight items now on the “Recent Files” list.

Summary of Changes in V. 4.70

· New image viewer on Image dialog, with scroll bars so you can see all parts of large images.

· Long “Options” menu broken into three: “Tags,” containing the tag coloring options, “Text,” containing the text options, and “Options,” containing the program options.

· Bug fixed that may have caused program error if accessing deleted or renamed files or directories.

Summary of Changes in V. 4.40

· Selected text can be made uppercase or lowercase (under “Options” menu).

· Status bar added with line count/total number of lines, total number of open files, caps lock, num lock, and insert on/off.

· An enhancement to the Character dialog allows you to replace many keyboard characters with HTML character codes.

· Find and Find and Replace have been rewritten to be more functional and consistent.  “Close All” added to “Edit” menu.

· A “Directories” menu shows the 8 most recently used directories and will open them (this has turned out to be an extremely convenient feature).

· A lot of improvements to the code, including better error-handling.

· When you “Save All” open files, the program returns you to file you were working on.

· It is now no longer possible to open more than one instance of a particular file.

· A button has been added for the alternate browser.

Summary of Changes in V. 4.0

· Fully NT-compatible.

· Multiple files can be selected, opened, and saved (“Save All” added to “Edit” menu).

· Replace dialog rewritten to include “Match Whole Word”; multiple-file search and replace, including Undo.

· All dialogs now “remember” their last position.

· Data can be imported and exported between dialogs.

· Template dialog added.

· Tags can be converted to upper- or lowercase.

· Hex Value dialog rewritten to include multiple color palettes (16 colors and “Web-safe” colors).

· Service Pack 3 fixed bug that prevented tags from coloring in files >32 kb.

· Additional user options.
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Complete Version History (Skipped Version Numbers Indicate Minor Changes)

Versions prior to v. 3.46 are unsupported and are not recommended!

3.46 (release version)

Full release version.
3.47 (beta)

Major improvements to Character dialog.

3.48 (beta)

Added option to have cursor back up so that it appears inside tags when tags are added. This is under the “Options” menu item (“Cursor Inside Tags”).

3.50 (beta)

Major changes to Tables and Forms dialogs.

3.54 (beta)

All dialogs now “remember” their last position and open in the same place they were left.

3.58 (beta)

Removed option to use background images on dialogs to help streamline program (there were a number of reasons for this). Made it possible to export data from dialogs to Define User Buttons dialog. Code optimization. Miscellaneous improvements and enhancements. Added Create Template dialog. Data can be imported from various dialogs to create user-defined templates.

3.59 (beta)

Improvements to interface. Combined Define User Buttons and User Buttons dialogs for more intuitive operation. Additional enhancements.

3.60 (beta)

Revamped interface. Put “Make Tags Uppercase” and “Make Tags Lowercase” back in. The routine now leaves the material between quote marks alone (thanks to Don of GreenGecko Software, who out of the blue offered me his help).

3.61 (beta)

Additional improvements to Create Template. Many additional enhancements.

3.62 (beta)

Removed captions from dialog menu buttons. The images are reasonably self-explanatory, and if you pause the mouse pointer over any of the buttons a Tool Tip will pop up explaining the button function. This allows more screen area for editing. You can also change both the back color and fore color of the text editing window. Removed the About box. Unnecessary at this point and just adding to the size of the program.

3.64 (beta)

Added option to start program with no open text window and option to start text window maximized or normally.

3.66 (beta)

Misc. fixes. Added centered and right-justified paragraph buttons to standard toolbar.

3.68 (beta)

Reduced number of user-defined buttons to 18 from 24. Fixed an odd glitch with the Frames and Form dialogs.

3.70 (beta)

Major changes to Create Template dialog. Major internal code changes. Misc.  fixes and enhancements.

3.71 (release version)

Compiled after installation of SP3, which fixes numerous problems with the Rich Text Box and other Visual Basic bugs. Includes major changes to the Character dialog and internal code enhancements. Visual Basic programmers should read the note at the top of this file before installing.

3.89 (beta)

Enhancements and improvements. Making tags uppercase or lowercase now skips over material between <!-- and -->.

3.93 (beta)

Added support for non-dithered “Web-safe” colors. Major enhancements to Hex Value dialog. Code optimization.

3.95 (beta)

Further enhancements to Hex Value dialog.

3.99 (beta)

Multiple files can be selected and opened simultaneously; “Save All” added to “Edit” menu (will save all open files). “Save All” does not work if you have newly created files that haven’t been saved once.

3.991 (beta)

Fix to multiple file open and save.
3.993 (beta)

Experimental multiple-file search and replace, including undo. PLEASE back up files before using this new feature. Not thoroughly tested.

3.994 (beta)

Multiple-file search and replace less buggy. Additional improvements.

3.999 (beta)

This version is NT-compatible! Fixed bug that caused a crash when using “Replace” under some circumstances. Added “Whole Word” to search criteria for “Replace.” Added About dialog back in.

4.0 (release version)

Full non-beta version.

4.04 (beta)

Added “Close All” to “Edit” menu. Added “Directories” menu item that lists recently used directories. Fixed but that prevented “Save All” from appearing on “Edit” menu under some circumstances.

4.09 (beta)

Changes to “Directories” menu item, including removal of “Clear Directories” (see “Clear Recent Files,” below). Fixed bug that caused program error if Default Directory were set to a directory on a Zip drive and then the directory was renamed or deleted. Removed “Clear Recent Files” from “Options” menu. There are only four things on the Recent Files list and the code involved to delete them wasn’t worth the overhead.

4.12 (beta)

More internal improvements. Added “Clear Recent Files” and “Clear Directory List” back to the “Options” menu. I figured out a way to optimize the code.

4.14 (beta)

Fixed an odd problem. Opening a file wouldn’t change the directory the program was accessing, so trying to view a file in a browser wouldn’t always display images. This “error” crept into the betas after the release of v. 4.0.

4.16 (beta)

Find and Find and Replace have been rewritten. At present, you can no longer choose the search direction.

4.17 (beta)

Further improvements to Find and Find and Replace. They no longer “loop” from the end of the file back to the beginning. There is still no search direction option.

4.22 (beta)

Button added to toolbar for alternate browser. Program will no longer open multiple instances of the same file. Additional code improvements.

4.27 (beta)

Bugs (I hope) worked out of Find and Find and Replace. Keyboard characters can now be replaced with HTML character codes using the Character dialog.  Additional code improvements.

4.30 (beta)

Two instances of the same file can no longer be opened. Status bar added at bottom, showing line number/total lines, number of open files, caps lock, num lock, and insert status. Major improvements to the Character dialog replace feature. A major bug was eliminated. Previously, closing the program with one of the dialogs minimized rather than closed would generate an error. The “Undo Last” on the Find and Replace dialog has been disabled until I track down a problem with it.

4.31 (beta)

Problem with “Undo Last” has been fixed.

4.32 (beta)

Problem with “Undo Last” not fixed! The “Undo” buttons on the Find and Replace dialog have been removed. At present, there is no practical way to incorporate them while preserving the non-modal state of the dialog (a modal dialog requires that you complete your actions and close the dialog before being able to do anything to the text). “Tool Tips” added to many of the forms (this is in progress); moving the mouse cursor to a particular button will give you a brief description of the button’s purpose.

4.33 (beta)

More bugs fixed! “Make Selected Text Uppercase” and “Make Selected Text Lowercase” added under “Options” menu.

4.40 (release version)

More bugs fixed! “Make Selected Text Uppercase” and “Make Selected Text Lowercase” added.

4.42 (beta)

Fixed a bug that may have caused a program error if the Default Directory were set and the directory deleted or renamed, or may have caused program errors if trying to access deleted or renamed files. This always happens within 48 hours after a new full version is released!

4.44 (beta)

Automatic tag coloring as you type and an option to use colored tags when adding data from dialogs. Long “Options” menu broken into three: “Tags,” containing the tag coloring options, “Text,” containing the text options, and “Options,” containing the program options.

4.46 (beta)

Fixed bug causing program error when “Uncolor Tags” selected. Fixed “File Not Found” error (I think).

4.47 (beta)

Fixed yet another bug in the Replace dialog that could cause the last word replaced during a search (NOT a “Replace All”) to be duplicated. When using the “List” dialog, list items were being added in reverse order! Fixed in 4.47.

4.51 (beta)

New image viewer, with scrollbars, for Image dialog. Many additional enhancements!

4.54 (beta)

Fixed bugs in Image dialog (image viewer); additional enhancements.

4.56 (beta)

Many enhancements to the dialogs!

4.58 (beta)

“Use Subdirectory Path” checkbox added to Image dialog; additional enhancements.

4.59 (beta)

Fixes problem with spell checking; fixes problem with inserting files into other files; Image dialog rewritten; other bug fixes and enhancements.

4.66 (beta)

Removed Rules dialog to free up some space, removed option to use “Absolute Path” (pointless), added options to “Use Path to Subdirectory from HTML Directory” to Body, Image, and Sound dialogs, many improvements to dialogs, many internal enhancements.

4.67 (beta)

Fixed glitch with browser buttons.

4.68 (beta)

Enhancements to the List dialog. Additional enhancements.

4.70 (release version)

Additions to “Insert” menu. Additional enhancements.

4.72 (beta)

Improvements to “Add Path to Subdirectory from HTML Directory” feature. Image and sound files can now be copied from one directory to another from the Image and Sound dialogs.

4.75 (beta)

More improvements and interface enhancements. Body dialog redesigned. Web-O-Rama now supports up to six user-defined browsers.

4.78 (beta)

Improvements to interface. Improvements to Tag List dialog.

4.79 (beta)

Links dialog fixed so it is once again possible to add the link source “by hand.”

4.80 (beta)

Fixed some serious bugs associated with the Body, Image, Links, and Sound dialogs, which were generating errors. Hasty coding was to blame!

4.82 (beta)

Improvements to the Body, Image, Links, and Sound dialogs. Option buttons added so any of the text boxes can be used for the file data.

4.83 to 4.89 (betas)

Code enhancements.

4.90 (beta)

Made toolbar buttons flat and redesigned some of the button graphics. Code enhancements.

4.91 (beta)

Fixed slight problem with Image dialog image viewer. Code enhancements.

4.92 (beta)

Made raised toolbar buttons an option. Code enhancements.

4.94 (beta)

Two options for cursor position added under “Options” menu. Code enhancements.

4.95 (beta)

“List” button added to toolbar. Enhancements.

4.96 (beta)

Fixes several problems, including a bug in the Metaname dialog that could cause a crash. Other enhancements.

4.97 (beta)

There was a problem with the “Find Microsoft Word” menu item. It wasn’t enabling the spell checking feature of the “Edit” menu. It has been fixed. Files larger than 32 kb, however, can only be checked in sections.

4.99 (beta)

All screen fonts available on your computer are now “gathered” by Web-O-Rama when you start the program. Although the program may appear sluggish when loading, you will be able to access the fonts from the various dialogs without “going out” to the Windows Font dialog. Selecting fonts (from drop-down lists) is significantly faster from the dialogs now! Removed option to color tags as you work. The code was clunky and slow. I intend to add it back in if Visual Basic 6 fixes some problems.

5.0 (beta)

“Spinner” controls added beside all text boxes that require numbers. Many enhancements and refinements.

5.03 (release version)

More improvements.

5.05 (beta)

“Tree View” added. This shows a list of currently open files. Clicking on a file will bring it to the front. This feature can be toggled on and off from the “View” menu. Cool.

5.07 (beta)

A third toolbar added with Font Face, Font Size, and Font Color drop-down lists. I found that I frequently wanted to change fonts quickly. Highlight a section of text and make a selection. You can only select one of the font attributes at a time. Use the Font dialog for adding multiple attributes.

5.09 (beta)

Improvements to some of the dialogs (Image dialog in particular). Code optimized.

5.11 (beta)

“Tree View” changed to “File View” (under the “View” menu) and is now the first tab on a left-aligned toolbar, providing a quick way to switch between open files. “Directories” is on the second tab and allows you to easily open files in the current, or any, directory. All toolbars can now be toggled on and off and their state will be “remembered.”

5.14 (beta)

Added “Save Color” panel to Hex Value dialog.

5.18 (final VB5 beta)

Improvements.

5.19 (beta)

Eliminated the Template dialog and added a Style Sheet dialog. Web-O-Rama has so many dialogs that Visual Basic sometimes locks up when I try to compile it. I had to remove something in order to add the Style Sheet dialog, and the Template dialog was the only one I could conscientiously remove. If you want templates, you can just create them as HTML files and save them.

Visual Basic 6 Installed

Please see install.doc for some Web-O-Rama installation concerns.
5.20 (beta)

For some reason, no one liked the Font toolbar, so I removed it. Code optimized. Visual Basic 6 controls have some new and interesting features. I’m still experimenting.

5.24 (beta)

All the toolbars (including the status bar, which is across the bottom) can be toggled on and off. Their state is remembered.

5.25 (beta)

Major cosmetic improvements to the dialogs. Additional miscellaneous code enhancements.

5.27 (beta)

Splash Screen added (can be turned off under “Options”). Improvements to Style Sheet dialog. It’s still not terribly intuitive, but will help those familiar with style sheets to construct them. A few of the Style Sheet options are not completely functional yet. Added a Date dialog (“Date” under the “Insert” menu).

5.30 (beta)

Tag List dialog completely rewritten. All tags for which I could find documentation are listed. Compatibility shown for both tags and attributes.

6.0 (release version)
Code cleaned up, miscellaneous enhancements and improvements.

6.02 (beta)

Two minor bugs fixed. Selecting an unavailable drive from the Directory View caused the program to crash. This has been fixed. Closing all open files, then opening File View and clicking on it would cause the program to crash. This has been fixed.

6.05 (beta)

Numerous file-handling glitches fixed. Canceling a print operation no longer generates an error. Copy File dialog added.

6.15 (beta)

The File View toolbar was removed. It had a fatal flaw that I spent many hours trying to debug. At some point during this process, I realized that I wasn’t even sure it was possible to fix. I am trying to come up with a more effective and bug-free implementation. Selecting multiple files to open with combined file-name lengths greater than 256 characters no longer generates an error.

6.21 (beta)

Many minor bugs fixed. Code optimized.

6.32 (release version)
Preferences dialog added. Most of the user-configurable preferences are now on this dialog. Problems using Microsoft Word as a spell checker have been more or less fixed. Cutting and pasting or copying and pasting no longer results in double-spaced material.

Service Pack 1 for Visual Basic 6 Installed

Updates some of the system files but has no functional effect on Web-O-Rama.
6.33 (release version)
Fixes some potential installation problems. Additional minor updates. Changes to readme.doc and install.doc.

6.40 (beta)

Improvements to the Preferences dialog. Choices, such as font and background color, now affect all open documents rather than just the one being viewed (previously, documents had to be closed and reopened before some of the changes would take effect). Horizontal Rule dialog added (button on toolbar). Other improvements.

6.46 (beta)

Recent Files and Recent Directories lists rewritten to show most recently opened file as first item. Code enhancements.

6.50 (release version)

Code enhancements.

6.51 (beta)

Fixed slight bug in Tag List dialog; misc. additional small fixes.

6.59 (beta)

Files, Tags, and Characters tabs added to main editing window. New Hex Value “Image Color” feature. “Export Data” tabs eliminated. Completely new Frames dialog. Many other improvements.

6.61 (beta)

Redesigned Links and Copy Files dialogs. Other improvements.

6.67 (beta)

The “Copy File” feature on several of the dialogs has been redesigned to be more intuitive. Additional interface improvements.

Service Pack 3 for Visual Basic 6 Installed

Updates some of the system files but has no functional effect on Web-O-Rama.
6.71 (release version)

Many additional improvements and refinements. The installation of Web-O-Rama should not have the same kinds of potential problems as earlier versions, due to Microsoft’s Service Pack 3 update. Due to sparse donations, this may be the last free version.
6.75 (beta)

Page Creator dialog added (under the “Insert” menu item). “Margin” tab added to Body dialog. “Insert Template” checkbox added to Body dialog.

6.81 (beta)

Fixed problems with Links dialog. Additional improvements and fixes.

6.87 (beta)

“HTML Document Type Declaration (DTD) Style” added to Preferences dialog (inexperienced users can leave at default setting). “Quick View” tab added to Image dialog. Minor glitches fixed in Page Creator dialog (meta tags now go in correct place, others). Additional improvements and fixes, including improved ability of Sound dialog to shut off sound.

6.89 (release version)

Bug in Metaname dialog fixed. I also went through the code for the entire program line by line, cleaning out unnecessary and inconsistent code. I discovered and repaired some minor coding oddities that may or may not have affected the program.

6.91 (beta)

“Remove HTML Tags from Text” added under Text menu item. Improvements to “Quick View” on Image dialog. General menu improvements.

6.92 (beta)

Help files added. Bug fixed that under certain circumstances allowed message boxes to open behind dialogs that were in the “on top” state, making the message boxes difficult to close.

6.97 (beta)

Chart added to Hex Value dialog displaying the 216 “Web-safe” (non-dithered) colors.

6.99 (beta)

Miscellaneous improvements.

7.01 (beta)

File drag and drop implemented, new splash screen, “Copy to Clipboard” feature added to dialogs, more coherent relative path implementation, many other improvements.

7.05 (release version)

Removed glitchy option to use Microsoft Word as external spell checker. Improvements.

(
Kevin Gunn

P.O. Box 442155

Lawrence  KS  66044-8933

E-mail: kgunn@cjnetworks.com

Home page: http://people.delphi.com/krgunn/index.html

